msys 다운로드

설치 프로그램 „mingw-static-libraries-6.1.0-x86.zip“, 요약 페이지에 주어진 다운로드 링크, 필수 조건으로 MinGW의 설치 된 복사본을 필요, 즉, MinGW는 이미 설치 되지 않은 경우, 설정 이 작동하지 않습니다. MinGW만 필요한 경우에는 다운로드하지 마십시오. MinGW를 설치하려면 Files->GCC 6.1.0으로 이동하여 „mingw-msys-core-6.1.0-x86.zip“을 다운로드하십시오. 이 설치 프로그램 („mingw-msys-코어-6.1.0-x86.exe“) 잘 작동 포함. 이전 비고 [무시]: [이 소프트웨어 패키지의 설치 프로그램에 문제가 있습니다. 설치 관리자는 폴더 C:MinGWbin, C:MinGW를 자체적으로 포함 및 C:MinGWlib를 만들 수 없으므로 „잘못된 폴더, 폴더가 존재하지 않는 등…“과 같은 오류가 발생합니다. 수동으로 생성되지 않은 경우. 이러한 3개의 폴더는 설치가 성공적으로 계속되려면 PC에서 수동으로 만들어야 합니다. 이제 설치 후 „bin“폴더에 GCC 및 G ++ 컴파일러에 대한 프로그램 (.exe 파일)이 없다는 것을 알게되었습니다. 나는이 패키지가 어떻게 작동하는지 또는 전혀 작동하는지 궁금합니다!] … msysDTK-1.0.1 패키지만 사용하는 경우 너무 오래된 m4-1.4만 설치합니다.

그러나 해결책은 대체 할 네이티브 m4를 빌드하는 *not *입니다. 당신은 m4-1.4.7 업데이트를 설치해야, 당신은 원래 패키지와 같은 장소에서 별도의 다운로드로 찾을 수 있습니다: 또한, 설치된 D : MSYS msys.bat는 유닉스 스타일의 LF 대신 라인에 대한 선끝의. 전원 셸을 열고 C:msysbinbash.exe –로그인 명령을 입력하여 MSYS 환경을 시작합니다. 여기에서 MSYS 다운로드 : http://www.mingw.org/wiki/msys 소스 포지 페이지에서 MSYS 버전 이라는 링크가 있어야합니다. MSYS-version.exe 파일을 받게 됩니다. msysDVLPR은 MSYS 개발을 위한 것입니다. MSYS 런타임 라이브러리의 상태는 Cygwin이 개발한 몇 가지 새로운 기능을 지원하지 않습니다. 따라서 누군가가 MSYS에 충분한 기능을 추가 할 때까지 GCC 및 binutils의 이전 버전을 사용해야합니다. 그래서, 아마도 다른 것으로 msysdvlpr을 대체 할 다른 계획이 없다? 나는 명령을 이해하지 못했다 (.. /path/to/configure)는 텍스트 직후상자에 „3을 사용하여 설치합니다…“ (나도 이해하지 못했던 텍스트). 깨달음 위키는 „./configure“와 „설치“를 제안하며, 이것은 효과가 있습니다.

(이 작업을 수행하기 전에 C:msys1.0etc프로필을 편집했습니다. 또한 msysdvvlpr은 가까운 장래에 업데이트될 가능성이 낮다는 점에 유의해야 합니다. MinGW-64 팀이 제공하는 최신 MSYS 지퍼 아카이브 및 MinGW-64 7-zip 아카이브를 다운로드하십시오. 후자를 풀려면 프로그램 7-zip이 필요합니다. MSYS는 UNIX 파일 시스템 계층 구조를 에뮬레이트합니다. 기본적으로 MSYS 디렉토리 C:MinGWmsys1.0은 루트 디렉토리/및 /usr로 탑재됩니다. D와 같은 전통적인 윈도우 드라이브 : 및 E : / d 또는 /e. 마운트 명령을 사용하여 개요를 얻을 수 있습니다 : 나는 msys가 꽤 잘 작동있어 몇 가지 단일 파일 C 및 c ++ 프로그램을 컴파일했기 때문에 `산성 테스트`를 제공하기로 결정했습니다… 실제 (리눅스 소스) 패키지에 대한 실제 `./configure`cmd를 실행하려고합니다.